Authentication Errors with Salesforce and Pardot Integrations

Incident Report for 6sense

Monitoring

Our Engineering team, in collaboration with Salesforce, has implemented the configuration changes related to Salesforce OAuth refresh-token behavior for the Connected Apps used by our ABM, Sales Intelligence (SI) and AI Email platforms.

We are actively monitoring the integrations to validate the effectiveness of these changes and to identify any potential downstream impact. At this time, customers whose Salesforce/Pardot integrations are currently authenticated and operating normally do not need to take any action.

Customers whose integration is currently disconnected or displaying an "Authentication Failed" error will still need to reauthenticate their connection to restore connectivity. Please navigate to Settings > Integrations > Salesforce/Pardot to complete the reauthentication.

We will continue to closely monitor the integrations and provide further updates as we validate the stability of the changes. We appreciate your patience and understanding while we work through this issue.
Posted Aug 17, 2026 - 14:21 UTC

Update

Update: Our Engineering team continues to work closely with Salesforce to address the authentication issue affecting a subset of customers using Salesforce-connected data sources.

For the Salesforce Connected App used by the 6sense ABM and Sales Intelligence (SI) platform, Salesforce has implemented a configuration change related to Salesforce OAuth refresh-token behavior. We are actively monitoring the effectiveness of this change to confirm that it prevents new unexpected integration disconnections.

Customers whose Salesforce/Pardot integration within the ABM or Sales Intelligence platform was previously disconnected or is currently displaying an "Authentication Failed" error will still need to reauthenticate their connection to restore connectivity. Please navigate to Settings > Integrations > Salesforce/Pardot to complete the reauthentication. Customers whose integrations are currently authenticated and operating normally do not need to take any action at this time.

For the AI Email platform, our investigation remains ongoing. We are continuing to work closely with Salesforce, as the configuration change has not yet been applied to the Salesforce Connected App used by AI Email. We will continue to provide updates as we make progress toward a long-term resolution.

We appreciate your patience and will continue to share updates as our investigation progresses.
Posted Aug 13, 2026 - 13:47 UTC

Update

Update: Our Engineering team continues to work closely with Salesforce on the investigation into the Salesforce authentication issue affecting a subset of customers using Salesforce-connected data sources, including CRM/MAP integrations and AI Email.

Since our last update, the investigation has progressed further and Salesforce Support has identified a Salesforce-managed backend configuration related to refresh-token expiration that may be contributing to the unexpected token expirations and resulting integration disconnections. This configuration is not exposed through the Salesforce user interface.

We are working with Salesforce to validate the impact of this configuration and determine whether a change will resolve the observed behavior. The validation is ongoing and we are continuing to monitor affected integrations while we work toward a long-term resolution.

Customers whose Salesforce/Pardot integration is currently disconnected or displaying an "Authentication Failed" error should reauthenticate their connection by navigating to Settings > Integrations > Salesforce/Pardot. Reauthentication continues to successfully restore connectivity for the majority of affected customers.

We understand the impact this issue may have on data synchronization and downstream processing and appreciate your continued patience.

We will provide further updates as our investigation and validation with Salesforce progresses.
Posted Aug 12, 2026 - 19:16 UTC

Update

Our Engineering team continues to actively investigate the Salesforce authentication issue affecting a subset of customers using Salesforce-connected data sources, including CRM /MAP integrations and AI Email.

Since our last update, our joint investigation with Salesforce has narrowed the issue to a Salesforce OAuth refresh-token configuration that may be contributing to the unexpected token expirations and resulting integration disconnections. Salesforce is currently validating a configuration change in a controlled environment to determine whether it resolves the observed behavior. We continue to work closely with Salesforce while this validation is underway.

Customers whose Salesforce / Pardot integration is affected may continue to see the connection enter a disconnected state, resulting in delayed data synchronization and downstream processing until the connection is successfully reauthenticated. As a workaround, customers experiencing an "Authentication Failed" error or a disconnected Salesforce / Pardot integration should reauthenticate their connection by navigating to Settings > Integrations > Salesforce / Pardot. Reauthentication continues to successfully restore connectivity for the majority of affected customers.

We appreciate your patience as we work with Salesforce to validate the underlying cause and implement a long-term resolution. We will continue to provide updates as more information becomes available.
Posted Aug 11, 2026 - 15:29 UTC

Update

Update: Our Engineering team continues to investigate the Salesforce authentication issue affecting a subset of customers using Salesforce-connected data sources, including CRM integrations and AI Email.

Our investigation indicates that the authentication failures originate outside of the 6sense platform and are related to Salesforce OAuth authentication. We have not identified any changes within the 6sense platform that would account for the observed behavior. As part of our investigation, we have observed a strong correlation between the timing of the affected connections and recent Salesforce OAuth refresh token behavior and we are actively working with Salesforce to determine the underlying cause and implement a long-term resolution.

Customers whose Salesforce integration is affected may see the connection enter a disconnected state, resulting in delayed data synchronization and downstream processing until the connection is successfully reauthenticated.

As a workaround, customers experiencing an "Authentication Failed" error or a disconnected Salesforce integration should reauthenticate their connection by navigating to Settings > Integrations > Salesforce. Reauthentication has successfully restored connectivity for the majority of affected customers.

We will continue to provide updates as our investigation progresses.
Posted Aug 10, 2026 - 18:44 UTC

Update

Update - We continue to investigate the Salesforce authentication issue affecting a subset of customers using Salesforce and Pardot integrations.
Based on our investigation to date, the issue appears to be related to Salesforce integration credential expiration and may result in affected integrations requiring reauthorization. Customers who see their Salesforce Integration in an Error status can continue to update their integration credentials as a workaround. If the issue persists after reauthorizing, please contact Support.
Our Engineering team remains actively engaged in identifying a long-term solution, and we will continue to share updates as our investigation progresses.
Posted Aug 07, 2026 - 13:48 UTC

Update

We are continuing to investigate this issue.
Posted Aug 06, 2026 - 13:55 UTC

Investigating

We are investigating an issue impacting a subset of customers using Salesforce and Pardot integrations. Affected customers may see an "Authentication Failed" error message when viewing their integration page.

As a mitigation, customers experiencing this issue can update their integration credentials, which may restore the connection. If the issue persists after updating the credentials, please contact Support for further assistance.

Our Engineering team is actively investigating the issue and we will provide additional updates as more information becomes available.
Posted Aug 06, 2026 - 07:41 UTC
This incident affects: Workflows and Orchestrations, Account Based Marketing, Conversational Email and Platform (Alerts).