The issue impacting the Sales Intelligence dashboards for customers using MS Dynamics has been resolved.
Thank you for your patience while this was in progress.
Posted Apr 15, 2025 - 16:41 UTC
Update
We are continuing to investigate this issue.
Posted Apr 15, 2025 - 16:40 UTC
Investigating
We’re currently investigating an issue affecting the Sales Intelligence Dashboard for customers using Microsoft Dynamics. At this time, dashboards are not returning data.
Please note that this issue is limited to customers on Microsoft Dynamics only.
Our Engineering team is actively working to identify the root cause and implement a fix as quickly as possible.
We appreciate your patience and understanding as we work to resolve this matter.